#!/bin/sh
# $Id: vst3sdk.SlackBuild,v 1.3 2025/01/04 22:38:49 root Exp root $
# Copyright 2025  Eric Hameleers, Eindhoven, NL
# All rights reserved.
#
#   Permission to use, copy, modify, and distribute this software for
#   any purpose with or without fee is hereby granted, provided that
#   the above copyright notice and this permission notice appear in all
#   copies.
#
#   THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
#   WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#   MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
#   IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
#   CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#   SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
#   LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
#   USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
#   ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
#   OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
#   OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
#   SUCH DAMAGE.
# -----------------------------------------------------------------------------
#
# Slackware SlackBuild script 
# ===========================
# By:          Eric Hameleers <alien@slackware.com>
# For:         vst3sdk
# Descr:       VST 3 Plug-In SDK
# URL:         https://github.com/steinbergmedia/vst3sdk
# Build needs: 
# Needs:       
# Changelog:   
# 3.7.12_build_20-1:
#              04/jan/2025 by Eric Hameleers <alien@slackware.com>
#              * Initial build.
# 
# Run 'sh vst3sdk.SlackBuild' to build a Slackware package.
# The package (.t?z) and .txt file as well as build logs are created in /tmp .
# Install the package using 'installpkg' or 'upgradepkg --install-new'.
#
# -----------------------------------------------------------------------------

PRGNAM=vst3sdk
SRCNAM=${PRGNAM}_complete
VERSION=${VERSION:-3.7.12_build_20}
BUILD=${BUILD:-1}
TAG=${TAG:-alien}
ARCH="noarch"

DOCS="index.html doc \
  LICENSE.txt README.md VST3_License_Agreement.pdf VST3_Usage_Guidelines.pdf"
EXTRADOCS="cmake/LICENSE.txt public.sdk/LICENSE.txt pluginterfaces/LICENSE.txt \
  doc/LICENSE.txt base/LICENSE.txt"

# Where do we look for sources?
SRCDIR=$(cd $(dirname $0); pwd)

# Place to build (TMP) package (PKG) and output (OUTPUT) the program:
TMP=${TMP:-/tmp/build}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

# If you want automatic download to work, supply a URL for 'SRCURL' below:
SOURCE="$SRCDIR/${SRCNAM}-${VERSION}.tar.gz"
SRCURL=""

# Use the src_checkout() function if no downloadable tarball exists.
# Check out sources from SVN/GIT and create a tarball of them.
# Examples for GIT and SVN repositories are given below:
src_checkout() {
  # Param #1 : index in the SOURCE[] array.
  # Param #2 : full path to where SOURCE[$1] tarball should be created.
  # Determine the tarball extension:
  PEXT=$(echo "${2}" | sed -r -e 's/.*[^.].(tar.xz|tar.gz|tar.bz2|tgz).*/\1/')
  case "$PEXT" in
    "tar.xz") TARCOMP="J" ;;
    "tar.gz") TARCOMP="z" ;;
    "tgz") TARCOMP="z" ;;
    "tar.bz2") TARCOMP="j" ;;
    *) echo "Archive can only have extension 'tar.xz', '.tar.gz' '.tar.bz2' or '.tgz'" ; exit 1 ;;
  esac
  # Determine the directory name to create for the archive root:
  PBASE=$(basename ${2} .${PEXT})
  # Determine the directory where we create our checkout:
  CODIR=$(dirname ${2})
  case ${1} in
  0) # This example assumes a GIT checkout:
     GITURI="https://github.com/steinbergmedia/"
     BRANCH="master" # change if needed, the default is usually OK.
     RETDIR=$(pwd)
     mkdir -p $CODIR/${PRGNAM}_temp_checkout_$$ \
       && cd $CODIR/${PRGNAM}_temp_checkout_$$
     # Clone all 8 repositories and check out the $VERSION tag:
     echo "Checking out $BRANCH at tag $VERSION from '$GITURI/$PRGNAM':"
     for REPO in $PRGNAM vst3_base vst3_cmake vst3_doc vst3_pluginterfaces vst3_public_sdk vstgui vst3_tutorials ; do
       git clone https://github.com/steinbergmedia/$REPO
     done \
       && cd $PRGNAM \
       && git checkout v${VERSION} \
       && git submodule init \
       && git config submodule.base.url ../vst3_base \
       && git config submodule.cmake.url ../vst3_cmake \
       && git config submodule.doc.url ../vst3_doc \
       && git config submodule.pluginterfaces.url ../vst3_pluginterfaces \
       && git config submodule.public.sdk.url ../vst3_public_sdk \
       && git config submodule.vstgui4.url ../vstgui \
       && git config submodule.tutorials.url ../vst3_tutorials \
       && git -c protocol.file.allow=always submodule update \
       && cd -
     mv -i $PRGNAM ${PBASE} \
       && cd ${PBASE} \
       && chown -R root:root . \
       && cd .. \
       && tar --exclude .git -${TARCOMP}cf ${2} ${PBASE}
     cd $RETDIR
     rm -rf $CODIR/${PRGNAM}_temp_checkout_$$ || true
     ;;
  *) # Do nothing
     ;;
  esac
}

##
## --- with a little luck, you won't have to edit below this point --- ##
##

# Exit the script on errors:
set -e
trap 'echo "$0 FAILED at line ${LINENO}" | tee $OUTPUT/error-${PRGNAM}.log' ERR
# Catch unitialized variables:
set -u
P1=${1:-1}

# Save old umask and set to 0022:
_UMASK_=$(umask)
umask 0022

# Create working directories:
mkdir -p $OUTPUT          # place for the package to be saved
mkdir -p $TMP/tmp-$PRGNAM # location to build the source
mkdir -p $PKG             # place for the package to be built
rm -rf $PKG/*             # always erase old package's contents
rm -rf $TMP/tmp-$PRGNAM/* # remove the remnants of previous build
rm -rf $OUTPUT/{checkout,configure,make,install,error,makepkg,patch}-$PRGNAM.log
                          # remove old log files

# Source file availability:
if ! [ -f ${SOURCE} ]; then
  echo "Source '$(basename ${SOURCE})' not available yet..."
  # Check if the $SRCDIR is writable at all - if not, download to $OUTPUT
  [ -w "$SRCDIR" ] || SOURCE="$OUTPUT/$(basename ${SOURCE})"
  if [ -f ${SOURCE} ]; then echo "Ah, found it!"; continue; fi
  if ! [ "x${SRCURL}" == "x" ]; then
    echo "Will download file to $(dirname $SOURCE)"
    wget --no-check-certificate -nv -T 20 -O "${SOURCE}" "${SRCURL}" || true
    if [ $? -ne 0 -o ! -s "${SOURCE}" ]; then
      echo "Fail to download '$(basename ${SOURCE})'. Aborting the build."
      mv -f "${SOURCE}" "${SOURCE}".FAIL
      exit 1
    fi
  else
    # Try if we have a SVN/CVS download routine for ${SOURCE}
    echo "Will checkout sources to $(dirname $SOURCE)"
    src_checkout 0 "${SOURCE}" 2>&1 > $OUTPUT/checkout-$(basename ${SOURCE}).log
  fi
  if [ ! -f "${SOURCE}" -o ! -s "${SOURCE}" ]; then
    echo "File '$(basename ${SOURCE})' not available. Aborting the build."
    exit 1
  fi
fi

if [ "$P1" == "--download" ]; then
  echo "Download complete."
  exit 0
fi

# --- PACKAGE BUILDING ---

echo "++"
echo "|| $PRGNAM-$VERSION"
echo "++"

cd $TMP/tmp-$PRGNAM
echo "Extracting the source archive(s) for $PRGNAM..."
tar -xf ${SOURCE}
cd ${SRCNAM}-${VERSION}
chown -R root:root .
chmod -R u+w,go+r-w,a+rX-st .

echo Building ...
# Merely copying files into the package:
mkdir -p $PKG/usr/include/$PRGNAM
cp -a CMakeLists.txt base cmake pluginterfaces public.sdk tutorials vstgui4 \
  $PKG/usr/include/$PRGNAM/
mkdir -p $PKG/usr/share/cmake/${PRGNAM}
cp -a cmake/modules/*.cmake $PKG/usr/share/cmake/${PRGNAM}/

# Install a pkgconfig file:
mkdir -p $PKG/usr/lib64/pkgconfig
cat <<EOT > $PKG/usr/lib64/pkgconfig/${PRGNAM}.pc
Name: $PRGNAM
Description: VST 3 Plug-In SDK
Version: $VERSION
Cflags: -I/usr/include/$PRGNAM
Libs:
EOT

# Add documentation:
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION || true
for DOCF in $EXTRADOCS ; do
  cp -a $DOCF $(echo $DOCF |sed -E 's%(\w+)/(\w+)%\2.\1%') \
  $PKG/usr/doc/$PRGNAM-$VERSION || true
done
cat $SRCDIR/$(basename $0) > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION
find $PKG/usr/doc -type f -exec chmod 644 {} \;

# Compress the man page(s):
if [ -d $PKG/usr/man ]; then
  find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
  for i in $(find $PKG/usr/man -type l -name "*.?") ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
fi

# Add a package description:
mkdir -p $PKG/install
cat $SRCDIR/slack-desc > $PKG/install/slack-desc

# Build the package:
cd $PKG
makepkg --linkadd y --chown n $OUTPUT/${PRGNAM}-${VERSION}-${ARCH}-${BUILD}${TAG}.${PKGTYPE:-txz} 2>&1 | tee $OUTPUT/makepkg-${PRGNAM}.log
cd $OUTPUT
md5sum ${PRGNAM}-${VERSION}-${ARCH}-${BUILD}${TAG}.${PKGTYPE:-txz} > ${PRGNAM}-${VERSION}-${ARCH}-${BUILD}${TAG}.${PKGTYPE:-txz}.md5
cd -
cat $PKG/install/slack-desc | grep "^${PRGNAM}" > $OUTPUT/${PRGNAM}-${VERSION}-${ARCH}-${BUILD}${TAG}.txt

# Restore the original umask:
umask ${_UMASK_}